iSmoothRun issues on Apple Watch

While using iSmoothRun Apple Watch app for TrainingPeaks pushed pace based interval running workouts, the watch has stopped announcing the expected pace to be maintained for each interval. It simply announces the duration of the interval and calls all intervals as “warmups”.

Also doing a double click on the workout on the phone app (as shown in the screenshot), only shows duration based details and no pace based details. Not sure if it is to do with the workout that is being pushed via TP or with how iSmoothRun is reading the TP workout data.


@kirti.rawat Can you let me know a few more things

When did first notice this issue?

Are the details showing up correctly in training peaks ? If possible share screenshot of the training peaks workout.

The issue has been there since I think early November last year, which is also the time when the post workout log started missing the interval details as shown in the second screen shot. Prior to that the app log used to share details of each time based intervals (duration, pace, cadence, etc.). Also shared below is the TP workout details screenshot.

I bought the app and took the pro subscription.
Loaded a dummy workout in TP. Everything looks good.

This is how its rendering for me

Both workouts are pace based. I also tested for power based and looked fine.

Next step would be to

  • Disconnect TP and iSM
  • Delete the app
  • Reinstall the app
  • Connect TP and iSM
1 Like

Done but still no pace data. How can we check what is coming in from TP?

Tp and iSM sync belongs to them. We can’t check.

As next step do 2 things.

  • enable all 3 hr, pace and power in EnduroCo and click on “update tomorrow’s workout in tp” button

  • create a dummy pace based workout in TP and see his that rendering.

Kill the app and reopen to see new workouts. See how all workouts are rendering.

If this doesn’t workout then I will need your TP account credentials to check stuff once.

Hi Rohan, hadn’t yet made the last recommended changes however on the run today, the interval pace announcements are back and it seems like the uninstall - reinstall solved the problem. Thanks for your help!

Phew… Had another app recommendation lined up incase this had persisted. Happy training

1 Like